Xantia radio

Our most popular forum is for Citroën problems, discussions and chat.
Specialising in AX, BX, ZX, Xantia,C5, Xsara, Saxo and XM. CX, 2cv & Berlingo, all are welcome.NOT for selling cars/parts!

Moderator: RichardW

davethewheel
Posts: 365
Joined: 04 Aug 2002, 04:01
Location:
My Cars:

Xantia radio

Post by davethewheel » 07 Aug 2002, 04:26

my 1996 Xantia has a problem with the radio which is original,it has poor recption ,will not stay on station has any one had this problem(maybe poor ariel connection ? ) cheers dave
0x

shaunthesheep
Posts: 364
Joined: 16 Jul 2002, 14:42
Location: United Kingdom
My Cars:

Post by shaunthesheep » 07 Aug 2002, 05:28

DAVE, you are not alone my dear chap.
my factory fitted xantia radio had the same problem, after lots of trips to get it repaired caused by various faults including the fault which you mentioned decided it was better to replace it with something better. now got a sony cd player works like a dream, and not problems (touch wood<img src=icon_smile_tongue.gif border=0 align=middle>)
dom
0x

mkelly1
Posts: 12
Joined: 03 Jul 2002, 18:14
Location: Australia
My Cars:

Post by mkelly1 » 05 Sep 2002, 06:25

shaun & dave,
1996 xantia i've had for 4 months had terrible radio reception (Phillips radio cassette) (i think this answer might also apply to kathbert's problem last month). finally traced the problem to the original aerial lead, which ends in a side-entry socket and connects to the radio via an adaptor plug. the pin in the centre of the lead socket is too short, and makes only intermittent contact with the adaptor plug thus causing all the problem. have made temp fix but intend to cut off lead socket and replace with plug for direct connection with radio. good luck.
0x

civvie
Posts: 215
Joined: 27 Feb 2002, 00:49
Location: west London,
My Cars:
x 2

Post by civvie » 06 Sep 2002, 03:09

Had the same problem as well with reception, the aerial fitted to the car was of the short type, moaned to the dealer and they fitted (screwed in) a longer aerial, reception was a lot better but as you all say radio is not that sensitive to signals.
Steve
0x

davethewheel
Posts: 365
Joined: 04 Aug 2002, 04:01
Location:
My Cars:

Post by davethewheel » 06 Sep 2002, 03:59

have tried the ariel connections both ends still poor recption i think i will replace the radio with a more modern one thanks all dave
0x

davethewheel
Posts: 365
Joined: 04 Aug 2002, 04:01
Location:
My Cars:

Post by davethewheel » 06 Sep 2002, 04:01

oops sorry about the poor spelling dave
0x