zx diesel - radio problem

Our most popular forum is for Citroën problems, discussions and chat.
Specialising in AX, BX, ZX, Xantia,C5, Xsara, Saxo and XM. CX, 2cv & Berlingo, all are welcome.NOT for selling cars/parts!

Moderator: RichardW

lesnajair
Posts: 39
Joined: Sat Aug 24, 2002 6:02 am
Location: United Kingdom
My Cars:

zx diesel - radio problem

Postby lesnajair » Sat Aug 24, 2002 6:41 am

Hello all!
As header, radio is intermittent. Original was working fine, but I changed it for a Pioneer RDS model which worked fine for about 8 months. Suspecting a problem with the new radio (intermittent sound/tuning/switching off - dodgy connection with face off plate) i swapped it for a brand new cd tuner. Connections are all ok as I've used connection adapters etc.
The tuning does not stop on stations to enter into memory. I'm thinking its now an aerial problem, as this also happened to the Pioneer. Is the aerial fused at all? Unlucky for me it only seems to receive radio 1 (strong signal).
Any advice greatly appreciated!
Thanks
Les
0 x

Dave Burns
Posts: 1934
Joined: Mon May 14, 2001 5:30 am
Location: United Kingdom
My Cars:

Postby Dave Burns » Sat Aug 24, 2002 4:52 pm

Are you saying it drift's off the station after tuning or that it doesn't hold the station in the memory preset.
Hehehe any radio that can only recieve radio 1 wants a shotgun taking to it<img src=icon_smile_big.gif border=0 align=middle>
Dave
0 x

andy99
Posts: 24
Joined: Sun Jul 07, 2002 4:57 pm
Location:
My Cars:

Postby andy99 » Sat Aug 24, 2002 6:15 pm

Radio 1 is the only station i can receive in this part of cornwall!! Thats why I only listen to CDs!!.
Sounds like the problem is a grounding fault. Im not an expert on it but from past experiences i would try replacing the aerial and the cable. There is no fuse on the cable as far as I know. You would need to check along the length of the cable to check the insulation is ok and nothing as cut into the cable. but for the small cost I would just put in a new one. Also check the aerial connection with the bodywork
0 x

NiSk
Posts: 1435
Joined: Thu Jan 24, 2002 9:11 pm
Location: Sweden
My Cars:

Postby NiSk » Mon Aug 26, 2002 1:05 pm

Hi Les,
What's your motor/year? Some of the newer Cit's (the ones with an aerial built into a window) have an aerial amplifier in the cicuit.
However, I would guess you've got a grounding problem. Try wiggling the base of the aerial and see if the reception improves.
//NiSk
0 x

Chris_L
Posts: 30
Joined: Tue Aug 27, 2002 4:41 pm
Location:
My Cars:

Postby Chris_L » Tue Aug 27, 2002 9:58 pm

Hi Les,
There are a couple of things you can easily check as a first off. First of all, ease the radio out so that you can still switch it on (if poss) and disconnect the aerial from the back. Now try and tune in your channels again. If you can still get Radio 1, your aerial's not working, so you could try attaching another one manually to see if its that. You could even use an old metal coat hanger or something to test this. Even a very unsophisticated aerial should pick up something if you have decent coverage. The other thing you might want to check is that the set is earthed correctly. With it eased out, you could try manually earthing the case of the set to the chassis and with the aerial reconnected, see whether you can get any stations.
I would suspect a break in the core of the aerial above anything else (whilst in the shielded section), but the above quick tests should work this out.
Cheers,
Chris
0 x

lesnajair
Posts: 39
Joined: Sat Aug 24, 2002 6:02 am
Location: United Kingdom
My Cars:

Postby lesnajair » Wed Aug 28, 2002 7:47 am

Hi again
Thanks for all the replies. I'm waiting for a spare couple of hours to try out your answers, and hopefully get it sorted! I'll let you know how I get on. Thanks again.
Les
0 x

lesnajair
Posts: 39
Joined: Sat Aug 24, 2002 6:02 am
Location: United Kingdom
My Cars:

Postby lesnajair » Fri Sep 13, 2002 4:15 am

Found it!
Centre pin in aerial cap was out a touch. Only held in by friction. Pushed it in and back to normal!!
Thanks to all who replied
Les
0 x


Return to “Citroën”

Who is online

Users browsing this forum: Bing [Bot], Yahoo [Bot] and 4 guests