ABS help!!!

Our most popular forum is for Citroën problems, discussions and chat.
Specialising in AX, BX, ZX, Xantia,C5, Xsara, Saxo and XM. CX, 2cv & Berlingo, all are welcome.NOT for selling cars/parts!

Moderator: RichardW

p.rourke
Posts: 5
Joined: 02 Aug 2002, 17:40
Location: United Kingdom
My Cars:

ABS help!!!

Post by p.rourke » 01 Sep 2002, 02:48

I had one of the ABS sensors replaced at the garage a week ago every thing was fine for a day or two then the ABS light started to stay on again, first intermittently then after a couple of days permanently. I was told at the garage that the fault would be with one of the other sensors and not a faulty new sensor (the garage didn’t check the sensor when I pointed out the problem)
When I turn the ignition switch there is a loud clunk the ABS light flickers then stays on. Also (I don’t know if this is connected) a clicking noise coming from near the fuse box similar in sound to the indicators but faster.
Hope this makes some kind of sense, as you’ve probably gathered Im not mechanically minded!
Any help appreciated
Cheers
Pete
0x

NiSk
Posts: 1422
Joined: 24 Jan 2002, 21:11
Location: Sweden
My Cars:

Post by NiSk » 02 Sep 2002, 12:25

Sounds like youv'e got relay problems. Try and locate which relay is buzzing; remove it and check the condition of the connectors. If possible exhange it for another relay and see if the buzzing goes away. If it does, the relay was at fault, if not, then it's the operating voltage to the relay that is causing the buzzing.
//NiSk
0x

RASCAM
Posts: 9
Joined: 09 Mar 2002, 18:29
Location: United Kingdom
My Cars:

Post by RASCAM » 02 Sep 2002, 13:05

Hello there,
What model and year is this on?
Richard
0x

p.rourke
Posts: 5
Joined: 02 Aug 2002, 17:40
Location: United Kingdom
My Cars:

Post by p.rourke » 02 Sep 2002, 16:15

xantia vsx 2.0 v6 1994 (L)
cheers
pete
0x