Throttle 2.0i 16v

Our most popular forum is for Citroën problems, discussions and chat.
Specialising in AX, BX, ZX, Xantia,C5, Xsara, Saxo and XM. CX, 2cv & Berlingo, all are welcome.NOT for selling cars/parts!

Moderator: RichardW

Niek
Posts: 135
Joined: 18 Sep 2002, 18:09
Location: Netherlands
My Cars:

Throttle 2.0i 16v

Post by Niek » 19 Sep 2002, 20:28

Hi,
Has anybody ever taken the throttle housing (incl. stepper motor) of the 2.0i 16v engine apart for a clean??
My Xm is a bit jerky when low in rpm (around 2000 rpm) and touching the throttle slightly. It works absolutely beautiful when accelerating hard.
I think that by cleaning the sensors in the housing (air temp/volume and throttle?) and maybe the stepper motor it will improve. Then again I don't know if there is anything to clean...
Niek.
0x

spanners
Posts: 77
Joined: 10 Sep 2002, 03:29
Location:
My Cars:

Post by spanners » 20 Sep 2002, 03:33

there is not a lot to clean on temp sensor is just a reed sensor hanging in airflow. you can wipe the dome end of the stepper motor but DO NOT force it in and out or you will damage the gear. as far as throttle butterfly just open butterfly and clean with toothbrush also make sure air holes are clear.map sensor just check for clear intact pipes. I would also invest in a proper citroen diagnostic report.
0x

Niek
Posts: 135
Joined: 18 Sep 2002, 18:09
Location: Netherlands
My Cars:

Post by Niek » 20 Sep 2002, 17:08

Hi,
Where can I find this MAP sensor? Is it in the throttle housing? (I take it the 2.0i 16v engines are the same on all cars Xm, Xantia, Xsara?)
Niek.
0x

spanners
Posts: 77
Joined: 10 Sep 2002, 03:29
Location:
My Cars:

Post by spanners » 21 Sep 2002, 00:09

the map sensor depending on system is usually bolted on inner arches or bulkhead black unit with electrical connector and small bore rubber hose(to be checked) which is connected to inlet manifold. some systems no seperate MAP sensor unit inside ECU.
0x

Niek
Posts: 135
Joined: 18 Sep 2002, 18:09
Location: Netherlands
My Cars:

Post by Niek » 25 Sep 2002, 13:19

Hi,
Sorry to keep digging this back up. I had a look at my throttle housing yesterday evening and found there were three connectors on them as well as a stepper motor.
Two connectors are on top of the housing, one of them stood out because it was yellow and had a sort of plastic bracket on it. The third connector is on the bottom of the housing.
Can anyone tell me what these do. (I'm talking about the RFV engine with the Motronic 5.1.1 ECU)
Also is there eny sealant between the housing and the inlet manifold it is bolted to? I haven't been able to find the MAP sensor yet.
Niek.
0x