xantia suspension faults 2.0 l hdi estate

Our most popular forum is for Citroën problems, discussions and chat.
Specialising in AX, BX, ZX, Xantia,C5, Xsara, Saxo and XM. CX, 2cv & Berlingo, all are welcome.NOT for selling cars/parts!

Moderator: RichardW

M.Davies
Posts: 2
Joined: 23 May 2001, 19:14
Location:
My Cars:

xantia suspension faults 2.0 l hdi estate

Post by M.Davies » 24 May 2001, 01:14

xantia suspension problems.
new rear h/adjuster fitted by dealer 26 th February.current faults ,raise to max and car raises to full height.return to intermediate car stays at full height. set to normal car lowers in front, rear stays up. set to lowest stting car sinks ok. set to normal car raises to normal.add weight to boot and car raises slowly remove weight and car rear stays up. what is wrong with this vehicle, please help.
0x

pwatson
Posts: 263
Joined: 22 Apr 2001, 03:02
Location: E Midlands
My Cars:

Post by pwatson » 24 May 2001, 03:59

Have you read the thread below - question by Chris Peddle on Xantia suspension which sounds exactly same as yours - some useful replies there?
PhilW
Phil
0x

Chris Peddie
Posts: 50
Joined: 29 Apr 2001, 17:04
Location:
My Cars:

Post by Chris Peddie » 28 May 2001, 23:09

Hi,
My problem is similar in that intermediate is the same as maximum (either going up from normal, or down from max.) but no-one I have spoken to can suggest a remedy for this. It means that the intermediate setting can't be used as the suspension is solid, making it too bouncy bouncy for my liking!.
After changing the accumulator (knackered if the pump ticks - when raising rear particularly) and anti-sink spheres, the speed of movement (upwards) was much better on my car so it may be worth checking these out? I think the condition of the LHM and return filters can affect the up/down speed as well. Anyone else any comments on this? All depends on the miles/age of car.
Hopefully this is some help, Chris
0x

M.Davies
Posts: 2
Joined: 23 May 2001, 19:14
Location:
My Cars:

Post by M.Davies » 31 May 2001, 20:41

Today the car went back to the dealer who found that the rear height adjuster fitted by them in February was not set up correctly and was 60 mm's out. Car now back to it's old self.Thanks for the replies. Mike.
0x