Strange aircon blower in Xantia

Our most popular forum is for Citroën problems, discussions and chat.
Specialising in AX, BX, ZX, Xantia,C5, Xsara, Saxo and XM. CX, 2cv & Berlingo, all are welcome.NOT for selling cars/parts!

Moderator: RichardW

Keriso
Posts: 9
Joined: 06 Jul 2001, 19:51
Location: Malaysia
My Cars:

Strange aircon blower in Xantia

Post by Keriso » 06 Jul 2001, 19:54

I encountered a strange behaviour in my aircon blower. For some reason, the blower changes speed and I could not adjust the speed at all. Either I use the auto or manual mode, the speed remains the same. This applies even when I put it in the "off" mode. What gives? Anyone experience this before and what can I do to overide this? However, i discover if i switch off the engine and restart it again, everything goes back to normal.
0x

Dave Burns
Posts: 1916
Joined: 14 May 2001, 05:30
Location: United Kingdom
My Cars:

Post by Dave Burns » 07 Jul 2001, 05:54

Sorry Keriso I can't help with your problem but on the subject of strange behaviour, what do you all make of this, my blower motor speed's up when the brake light's come on, is my Xantia the only one to do this, I would be amazed and very gratefull if anybody can put their finger on the cause of this, of all the cars i've had there hasn't been one of them that's as poor as the Xantia for electrical fault's, it's a nice ride and a nice drive but sod it, no more after this one.
Dave
0x

Who is online

Users browsing this forum: Ahrefs [Bot], Bing [Bot], CommonCrawl [Bot] and 0 guests