2cv kangaroo juice????

Our most popular forum is for Citroën problems, discussions and chat.
Specialising in AX, BX, ZX, Xantia,C5, Xsara, Saxo and XM. CX, 2cv & Berlingo, all are welcome.NOT for selling cars/parts!

Moderator: RichardW

empty66
Posts: 5
Joined: Tue Jul 10, 2001 2:15 am
Location: United Kingdom
My Cars:

2cv kangaroo juice????

Postby empty66 » Thu Nov 08, 2001 4:29 am

help
have a 2cv charleston A reg
has an intermitent kangaroo impression fault
she starts no problem, but after a few metres
starts missing as if no fuel then firing missing.only for about 4 or 5 miles then drives fine.it might not happen again for 1,2,3,4,5 or more starts, then it will happen again.
points and timing have been done,fuel filter fitted,carb cleaned out,new plugs ,new leads.
could it be the fuel pump??totally baffled???
please help
0 x

David.Cox
Posts: 42
Joined: Sat Apr 21, 2001 1:49 pm
Location: United Kingdom
My Cars:

Postby David.Cox » Mon Nov 19, 2001 8:19 am

Pity nobody has replied before. Have only just come back to this forum after a break. I would strongly suspect the fuel pump, which may have its internal membrane/filter blocked partially. Doesn't cost much for new one though fitting is fiddly. Try taking off the rubber pipe from the fuel filter to the carb and turn engine over to see if fuel comes through evenly ( taking app precaautions about what happens to the petrol.
The only other thing is whether there is something blocking in a carb jet, but I am not a wizz at carbs.
Other source of advice would be the Yahoo message borad devoted to 2CVs which has masses of experts on it, and it is easy to register. The home page ofr this is
http://groups.yahoo.com/group/2cv-l
0 x


Return to “Citroën”

Who is online

Users browsing this forum: Bing [Bot], Cutac, Paul-R and 17 guests