Xantia Suspension.........Again !

Our most popular forum is for Citroën problems, discussions and chat.
Specialising in AX, BX, ZX, Xantia,C5, Xsara, Saxo and XM. CX, 2cv & Berlingo, all are welcome.NOT for selling cars/parts!

Moderator: RichardW

caeclyd
Posts: 64
Joined: 07 Jul 2001, 15:11
Location: United Kingdom
My Cars:

Xantia Suspension.........Again !

Post by caeclyd » 12 Nov 2001, 01:19

Can somebody please answer the following questions.
My 95 Xantia 1.9d has a very hard ride whenever i hit minor bumps/undulations in the road it feels like a kick in the arse.
I have changed the accumulator sphere at the front as there were 10 clicks per min ! The clicks are gone but there is no improvement in ride.
LHM fluid levels are ok
Should I change all spheres & LHM?
How do you drain the LHM?
Many thanks.
Rory
<img src=icon_smile_question.gif border=0 align=middle>
0x

Dave Burns
Posts: 1916
Joined: 14 May 2001, 05:30
Location: United Kingdom
My Cars:

Post by Dave Burns » 12 Nov 2001, 01:53

Sounds like you have one or more shot suspension sphere(s), with the car on level ground and at normal ride height, bounce the car at all four corners, spheres that have gone bad wont give much and should be easily detectable, to drain lhm, lower the suspension to minimum and loosen the pressure relief screw (12mm) on the regulator, a hissing sound should be heard as the accumulator sphere discharges, remove the wire clip from the reservoir and lift out the centre piece with the pipes attached, unbolt and lift out the reservoir for draianing and cleaning, you may want to flush the system out with hydraflush which should be left in for about 1000 miles, then do it all again and replace with new lhm.
good luck
Dave
0x

caeclyd
Posts: 64
Joined: 07 Jul 2001, 15:11
Location: United Kingdom
My Cars:

Post by caeclyd » 22 Nov 2001, 02:28

Thanks for the advice Dave.
For the first time in 15 years I had to call in the cavalry. Could I get the rear spheres off. Not a chance. Before I did some damage to the pipes etc I had to give up. I drove the car to a local garage with the suspension fully down (I had punctred a sphere in an attempt to remove it).
The garage charged me £40 to remove all spheres and in the process they broke their Snap on oil filter remover 3" type !!.
As you suggested I drained the tank ,lots of grit & cleaned the filters.
The car is now as smooth as silk.
It should be OK for another 190,000 miles yes that is correct.
Bye for now,
Rory
0x