Xantia noise at front right

Our most popular forum is for Citroën problems, discussions and chat.
Specialising in AX, BX, ZX, Xantia,C5, Xsara, Saxo and XM. CX, 2cv & Berlingo, all are welcome.NOT for selling cars/parts!

Moderator: RichardW

andy hannett
Posts: 24
Joined: 07 Feb 2001, 01:05
Location: United Kingdom
My Cars:

Xantia noise at front right

Post by andy hannett » 14 Feb 2001, 02:26

i have recently noticed a speed related noise from the front drivers side of the vehicle when turning slightly to the left.
the noise is very reminiscent of a sick petrol station compressor and sometimes causes a vibration in the steering wheel.
as this noise is coming from near the alternator, i think that it may be the hydraulic pump or possibly something to do with the steering rack assembly.
has anyone had a similar problem, if so some advice would be helpfull.
Many thanks
0x

jmd
Posts: 398
Joined: 18 Feb 2001, 07:18
Location: Ireland
My Cars:
x 1

Post by jmd » 18 Feb 2001, 07:22

If it is the Alternator, the noise should be present all the time. Check the boots on the universal joints(beside the wheel)it may be split.
0x

david webzell
Posts: 5
Joined: 21 Feb 2001, 05:45
Location: United Kingdom
My Cars:

Post by david webzell » 21 Feb 2001, 06:07

[quote]
i have recently noticed a speed related noise from the front drivers side of the vehicle when turning slightly to the left.
the noise is very reminiscent of a sick petrol station compressor and sometimes causes a vibration in the steering wheel.
as this noise is coming from near the alternator, i think that it may be the hydraulic pump or possibly something to do with the steering rack assembly.
has anyone had a similar problem, if so some advice would be helpfull.
Many thanks

[/quote) If your Xantia has ABS you could also check to see if the wheel bearing is worn and the ABS sensor is rubbing.
0x

andy hannett
Posts: 24
Joined: 07 Feb 2001, 01:05
Location: United Kingdom
My Cars:

Post by andy hannett » 02 Mar 2001, 01:29

thanks david
my xantia does have ABS and the sensor is slightly worn but the dealer assured me the wheel bearings are OK during recent MOT. i have come to the conclusion that the drive shaft is on its way out, though its funny that it is only intermittent.
Many thanks
0x