Knocking on rear offside wheel / axle on ZX

Our most popular forum is for Citroën problems, discussions and chat.
Specialising in AX, BX, ZX, Xantia,C5, Xsara, Saxo and XM. CX, 2cv & Berlingo, all are welcome.NOT for selling cars/parts!

Moderator: RichardW

andyg
Posts: 40
Joined: 15 Apr 2002, 22:26
Location:
My Cars:

Knocking on rear offside wheel / axle on ZX

Post by andyg » 16 Apr 2002, 12:19

I have a knocking / banging noise from the rear offside wheel area, it appears only either under braking down an incline at speeds from 40mph to 10mph and on sharp left-handers, basically-when the wheel becomes light, the noise appears. Can anyone help??
I have changed the the rear shocks, i have changed the complete rear subframe (because the radius arm bearings were shot) but i did not change the four mounting as they appeared ok, the rear calipers have been rebuilt, the wheel bearings appear ok - i am at a loss, PLEASE HELP.
I have a ZX 1.9TD Volcane
0x

madpenguin
Posts: 27
Joined: 06 Feb 2001, 17:03
Location: United Kingdom
My Cars:

Post by madpenguin » 16 Apr 2002, 15:17

Andy,
The easiest way to check the subframe mounts is to jack the rear of the car up and see if the frame drops slightly. If it does, then they need replacing.
Also, it might be worth checking for a lose exhaust. I had a similar problem once, thought it might be the subframe, then the exhaust fell off.
Good luck
0x

andyg
Posts: 40
Joined: 15 Apr 2002, 22:26
Location:
My Cars:

Post by andyg » 16 Apr 2002, 15:53

Ian,
Thanks for quick reply, i will try your way of checking the sub frame mounts at first opportunity. The exhaust is a brand new handmade stainless steel system from Powerflow and is rock solid as regards vibration and contact with any other part of the chassis.
0x