ZX-strange noise when turning...

Our most popular forum is for Citroën problems, discussions and chat.
Specialising in AX, BX, ZX, Xantia,C5, Xsara, Saxo and XM. CX, 2cv & Berlingo, all are welcome.NOT for selling cars/parts!

Moderator: RichardW

MiX
Posts: 30
Joined: 03 Jun 2002, 04:57
Location: Norway
My Cars:

ZX-strange noise when turning...

Post by MiX » 03 Jun 2002, 05:20

Hi.
I bought a ZX 2.0 16v '93-model a few months ago. When I make a sharp turn with the car (at low speeds, mainly noticed when parking, and ONLY in wet conditions) I hear a strange noise sounding something like a "clonk"<img src=icon_smile.gif border=0 align=middle> from the front of the car. Maybe coming from the shock's or springs. I wonder if anyone has some clue of what's making this sound?
All replies are welcome<img src=icon_smile.gif border=0 align=middle>
Jarle,
Norway
0x

Dave Burns
Posts: 1916
Joined: 14 May 2001, 05:30
Location: United Kingdom
My Cars:

Post by Dave Burns » 03 Jun 2002, 20:37

The only thing I can think of is the ball race (thrust bearing ) on top of the suspension strut, they are'nt sealed to well from what I can remember.
Get someone to turn the steering from lock to lock while you observe the top of the suspension spring, it should turn smoothly with the rest of the strut, if it does not then the bearing must be suspect.
Dave
0x

Dave1
Posts: 195
Joined: 18 Apr 2001, 02:09
Location:
My Cars:

Post by Dave1 » 04 Jun 2002, 00:39

Strange clonk from the front! Been there before. My turned out to be a worn bolt in the swivel joint. See my previous post about this. May or may not be the same thing but I used to get a clonk when turning too. Now I just replace discs a lot!<img src=icon_smile.gif border=0 align=middle>
Good Luck
Dave
0x