xantia sx

Our most popular forum is for Citroën problems, discussions and chat.
Specialising in AX, BX, ZX, Xantia,C5, Xsara, Saxo and XM. CX, 2cv & Berlingo, all are welcome.NOT for selling cars/parts!

Moderator: RichardW

kathbert
Posts: 19
Joined: 06 Jul 2002, 06:01
Location: United Kingdom
My Cars:

xantia sx

Post by kathbert » 06 Jul 2002, 06:26

This xantias radio suffers from very bad interferance on the am bands,
could someone tell me how to (a) get the fitted radio out of the console, and (b) the best way to get to the aerial connection on the roof aerial. as I suspect a bad co-ax connection either at the radio end or the aerial end.
0x

mkelly1
Posts: 12
Joined: 03 Jul 2002, 18:14
Location: Australia
My Cars:

Post by mkelly1 » 06 Jul 2002, 13:43

Actually I get this a lot too, mainly in my local area (Sydney) which is matted with power lines I had been blaming for this effect. I too suspect an aerial fault and will now check it out with renewed confidence and let you know the outcome.
Michael
<BLOCKQUOTE id=quote><font size=1 face="Verdana, Arial, Helvetica" id=quote>quote:<hr height=1 noshade id=quote>
This xantias radio suffers from very bad interferance on the am bands,
could someone tell me how to (a) get the fitted radio out of the console, and (b) the best way to get to the aerial connection on the roof aerial. as I suspect a bad co-ax connection either at the radio end or the aerial end.

<hr height=1 noshade id=quote></BLOCKQUOTE id=quote></font id=quote><font face="Verdana, Arial, Helvetica" size=2 id=quote>
0x

mkelly1
Posts: 12
Joined: 03 Jul 2002, 18:14
Location: Australia
My Cars:

Post by mkelly1 » 05 Sep 2002, 06:45

kathbert,
i did finally check this out on my Phillips radio-cassette. see posting of today's date on similar problem. michael
0x

shaunthesheep
Posts: 364
Joined: 16 Jul 2002, 14:42
Location: United Kingdom
My Cars:

Post by shaunthesheep » 05 Sep 2002, 22:55

kathbert,
this interference you mentioned does it just appear on the am bands & was the engine running?
also you asked how to remove the stereo from the facia, there is two torx screws locted at the bottom of the heater/radio surround, above where the ashtray remove's from, reomve screws, pull surround gentle with the aid of a little screwdriver to release the clip ontop of the heater controls, that should then give you access to the screws that are holding in the stereo it's self are on the side.
dom
Edited by - shaunthesheep on 05 Sep 2002 21:34:06
0x

kathbert
Posts: 19
Joined: 06 Jul 2002, 06:01
Location: United Kingdom
My Cars:

Post by kathbert » 06 Sep 2002, 03:12

Thanks everyone for all the help, The problem was the aerial connection at the radio end. Cleaning the earth shroud on the connector cleared the problem. cheers.
0x